Welcome Guest!!!

Thank you for visiting the GM Kappa Performance Forum. This forum is the only performance oriented forum for all GM Kappa Platform Enthusiasts.  We hope you will join and share your experiences.  Becoming a member is FREE! If you want to advertise on this forum, email KappaPerformance at yahoo.com.


Registration required to view the forum attachments. Below is a sample of the current top 25 topics.
Supporting Membership has many advantages.


More information on becoming a supporting member or vendor can be found on the sub forum; Site Help and Suggestions; thread - Supporting Members and Vendors.

Author Topic: Backfire with power loss  (Read 8172 times)

0 Members and 1 Guest are viewing this topic.

Offline tazz

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1621
  • Karma: +1/-2
  • Location: Somewhere
Re: Backfire with power loss
« Reply #50 on: December 28, 2014, 09:01:13 PM »
I didnt even see that but yeah it should read .something .3-.8 at idle.
If its not the MAF per se it could be one of the pins or wires that carry the signal from the MAF.
Thought he tried a NEW MAF with same issues.
If the car ran fine without the MAF and he tried a new MAF my guess would then be the wire harness to the MAF. 

Offline roxer

  • Supporting Member
  • Master Tech
  • *
  • Posts: 426
  • Karma: +3/-1
  • Location: NC
Re: Backfire with power loss
« Reply #51 on: December 28, 2014, 10:12:42 PM »
I checked to see if there was voltage to the MAF and got 11vdc. So I'm not getting long term fuel trims or MAF info. So the problem has to be somewhere else other than the actual MAF.  When I disconnected the MAF and drove it, the turbo worked, but the engine still ran erratic.
« Last Edit: December 28, 2014, 10:42:30 PM by roxer »
2002 Isuzu Rodeo Sport - Still kicking!
2008 Polar Sky Redline - Auto - Fully Loaded
2007 Mysterious Solstice GXP - Current list of Mods

Offline tazz

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1621
  • Karma: +1/-2
  • Location: Somewhere
Re: Backfire with power loss
« Reply #52 on: December 28, 2014, 11:03:48 PM »
Yeah if your MAF fails the car runs off of speed density tables.

Offline LatinVenom

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 2615
  • Karma: +6/-5
  • Location: South Florida
Re: Backfire with power loss
« Reply #53 on: December 29, 2014, 06:09:03 PM »
We are giving you the answer, you have a MAF issue. I know you tried a new MAF, however I would try another one and make sure you install it correctly.
Solstice GXP 2007.
Aggressive and fully loaded.
Mods: Magnaflow 2.5" exhaust, DDM Backbone & ProBeam,ZOK suspension,LV Kappa Front Chassis Brace, BTF Turbo Upgraded Wheel, Windristrictor, JPM Center console,arms,tulip,side doors,DDM Upgraded wheel tune.

Offline tazz

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1621
  • Karma: +1/-2
  • Location: Somewhere
Re: Backfire with power loss
« Reply #54 on: December 29, 2014, 06:23:20 PM »
I can send you a known working OEM MAF just to try if you like.

Offline Critterman

  • Retired, thank you very much
  • Lifetime Supporting
  • General Manager
  • *
  • Posts: 12432
  • Karma: +17/-56
  • Baltimore/Washington Corridor
Re: Backfire with power loss
« Reply #55 on: December 29, 2014, 07:42:54 PM »
My recommendation is to have Tazz send you a known working sensor, and you send yours to him.  He can put it on his car and see if his readings change.  If he gets readings and you don't then we will all know it is your wiring that is the issue.
2006 Cool named BIXABEL (BISH-AH-BEL) Mayan for "Good Roads"

DDM
StageIII intercooled Supercharger, Wisco ceramic coated pistons, Carrillo rods, superTech valves and Springs
Ported and polished head
Exedy Stage II Clutch
big brake kit, slotted/drilled Rotors w/Porterfield pads & blue juice
Backbone, Probeam, Cross Strut Brace
Underhood, trunk, & door Lights
ZOK suspension
Lambo Doors

JPM
Center console, door inserts, & dash
Seat bolster & lumbar support

Focuztech Tri-Y Header & hi-flow cat
Solo Performance SQR-2
Norm's Rear facia
Heated Seats
Black Cat inserts

Offline Sol Asylum

  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8901
  • Karma: +35/-64
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Re: Backfire with power loss
« Reply #56 on: December 29, 2014, 09:15:41 PM »
Why not just swap it with the one in his other Kappa?
2007 Aggressive GXP

Offline tazz

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1621
  • Karma: +1/-2
  • Location: Somewhere
Re: Backfire with power loss
« Reply #57 on: December 29, 2014, 10:28:34 PM »
yes that would be smart.

Offline roxer

  • Supporting Member
  • Master Tech
  • *
  • Posts: 426
  • Karma: +3/-1
  • Location: NC
Re: Backfire with power loss
« Reply #58 on: December 29, 2014, 11:52:00 PM »
Mega thanks to all.  I did just that today and got it to work - sort of.  So it worked for a few minutes until I moved the wiring bundle and connector. So now I know I had two problems. Originally a bad MAF AND lose power pin/wire in the GM CAI extended MAF cable. When I checked power previously, it was from the primary connector and not from the extended cable end. I also checked my MAF in the SKY and got it to puke.

I didn't notice the wiring problem until I plugged in the extended cable and saw a wire push when I locked it. I was able to push it back in and then had continuous power at the end connector.  Damn, just damn. What a stupid find. So I'm back in business now.

Again, big thanks to everyone. No way I could have done this without the help of the board. You guys rock.
2002 Isuzu Rodeo Sport - Still kicking!
2008 Polar Sky Redline - Auto - Fully Loaded
2007 Mysterious Solstice GXP - Current list of Mods

Offline tazz

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1621
  • Karma: +1/-2
  • Location: Somewhere
Re: Backfire with power loss
« Reply #59 on: December 30, 2014, 12:25:06 AM »
Interesting note on my GMPP CAI connector.  I bought my GMPP CAI from a Saturn dealer in Arizona it was a display model had the MAF and everything already connected (that's how i acquired a extra MAF).  Well installed and the thing pops a MAF code looked at all the wires everything fine.  Connected it and MAf code pops tested all the wires at the connector extender and found that one of the wire was actually out of sequence for whatever reason.  So I had to carefully take two wires with pins out of one end connector and put them in proper sequence after that it worked perfect. 

Offline Critterman

  • Retired, thank you very much
  • Lifetime Supporting
  • General Manager
  • *
  • Posts: 12432
  • Karma: +17/-56
  • Baltimore/Washington Corridor
Re: Backfire with power loss
« Reply #60 on: December 30, 2014, 12:54:45 PM »
Well it is great that it is now working, good job
2006 Cool named BIXABEL (BISH-AH-BEL) Mayan for "Good Roads"

DDM
StageIII intercooled Supercharger, Wisco ceramic coated pistons, Carrillo rods, superTech valves and Springs
Ported and polished head
Exedy Stage II Clutch
big brake kit, slotted/drilled Rotors w/Porterfield pads & blue juice
Backbone, Probeam, Cross Strut Brace
Underhood, trunk, & door Lights
ZOK suspension
Lambo Doors

JPM
Center console, door inserts, & dash
Seat bolster & lumbar support

Focuztech Tri-Y Header & hi-flow cat
Solo Performance SQR-2
Norm's Rear facia
Heated Seats
Black Cat inserts

Offline WWI Flying Ace

  • Master Tech
  • ***
  • Posts: 118
  • Karma: +0/-2
Re: Backfire with power loss
« Reply #61 on: December 30, 2014, 04:08:09 PM »
I can send you a known working OEM MAF just to try if you like.

:)
I never wonder to see men wicked, but I often wonder to see them not ashamed.
-Jonathan Swift

Offline LatinVenom

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 2615
  • Karma: +6/-5
  • Location: South Florida
Re: Backfire with power loss
« Reply #62 on: December 30, 2014, 06:59:28 PM »
This issue of a pin been pushed out is also present in the connection to the solenoid that drives the waste gate.
Glad it was resolved.
Solstice GXP 2007.
Aggressive and fully loaded.
Mods: Magnaflow 2.5" exhaust, DDM Backbone & ProBeam,ZOK suspension,LV Kappa Front Chassis Brace, BTF Turbo Upgraded Wheel, Windristrictor, JPM Center console,arms,tulip,side doors,DDM Upgraded wheel tune.

Offline roxer

  • Supporting Member
  • Master Tech
  • *
  • Posts: 426
  • Karma: +3/-1
  • Location: NC
Re: Backfire with power loss
« Reply #63 on: December 30, 2014, 10:46:58 PM »
This issue of a pin been pushed out is also present in the connection to the solenoid that drives the waste gate.
Glad it was resolved.

The sad part is, I didn't see this sooner. I only noticed it by chance.  Maybe because my hand usually covered the area behind the connector where the wire was. But even looking directly at it, the pins were always right.  :gaah:  I can say it's a sad day a 10yr aircraft electrician misses that.   :nuts:
2002 Isuzu Rodeo Sport - Still kicking!
2008 Polar Sky Redline - Auto - Fully Loaded
2007 Mysterious Solstice GXP - Current list of Mods

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7512
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Backfire with power loss
« Reply #64 on: December 30, 2014, 11:53:04 PM »
What's important is that you found the problem. Good stuff!
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline JesseB

  • Tech
  • **
  • Posts: 90
  • Karma: +0/-1
  • Location: South Eastern Ohio
Re: Backfire with power loss
« Reply #65 on: January 05, 2015, 11:22:06 AM »
Hey Roxer, just wondering if you have gotten this fixed? I dont know if my situation is at all the same, but I noticed some pretty loud backfiring under WOT the other week. Once I changed spark plugs (and gapped them correctly) the problem was completely fixed. Could be something to check out although mine never stalled, threw any codes, or lost any power...but just wanting to share
« Last Edit: January 05, 2015, 11:25:07 AM by JesseB »
DDM Short Shifter, K&N Typhoon CAI, Solo HighFlow Cat, Solo Street Race Exhaust, Pwerks Charge Tubes, Pwerks Street Race Intercooler, AEM Meth Injection, Pwerks Valve Springs, Wiseco Pistons, ZZP 4340 Rods, ARP Head Studs, Pwerks Street Race Head Gasket, Pwerks Phenolic Spacer Set, ZZP Stage 1 Comp Cams w/ Upgraded Fuel Pump Lobe, Spec Stage 2+ Clutch, Spec Lightweight Aluminum Flywheel, Pwerks 5th Injector, Pwerks 700hp Fuel Pump, ...& A TURBO

 

Powered by EzPortal