Welcome Guest!!!

Thank you for visiting the GM Kappa Performance Forum. This forum is the only performance oriented forum for all GM Kappa Platform Enthusiasts.  We hope you will join and share your experiences.  Becoming a member is FREE! If you want to advertise on this forum, email KappaPerformance at yahoo.com.


Registration required to view the forum attachments. Below is a sample of the current top 25 topics.
Supporting Membership has many advantages.


More information on becoming a supporting member or vendor can be found on the sub forum; Site Help and Suggestions; thread - Supporting Members and Vendors.

Author Topic: Thinking I have a leak somewhere.  (Read 634 times)

0 Members and 1 Guest are viewing this topic.

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Thinking I have a leak somewhere.
« on: October 09, 2017, 01:16:35 PM »
Car has run great since new and I knew this day was coming.

Took a 5 hour run back from visiting our new great-grandson. Driving on the hwy I stomped on it to pass and it got up and went but it didn't feel right. It was surging and hesitating but when I backed off all was well. I didn't have the DIC set to display boost so I figured it was anomaly.

A while later I got on it again and same result. Under heavy boost it would hesitate and backfire  as I shed speed, more than what it usually does with the RCD exhaust  with resonators on the GXP.

NEXT TIME I had to hit it to get around someone I did the same thing but this time I switched the DIC to show boost. I was probably pushing it more than I would have but I needed to get a handle on what the hell was going on. The boost built to 24 PSI with some hesitation and although I was still on the throttle and still accelerating, the display suddenly went from 24 to ZERO PSI.

Under 0 boost the thing runs fine and even with moderate boost of maybe 8 or 9 PSI there are no issues. Seems I only have a problem with maybe double digit boost. No codes are set, at least ones that will turn on the CEL but will scan for codes just the same.

I have T bolt clamps everywhere and the intercooler looks good from the front, wonder if I have a blowout on the back. Have to pressure test tomorrow as I have to leave for work in a few minutes.

Any other thoughts?
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline 2kwk4u

  • not really THAT quick
  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 1412
  • Karma: +8/-4
  • Location: Frederick, Maryland
    • '06 Solstice bits and pieces photo gallery
Re: Thinking I have a leak somewhere.
« Reply #1 on: October 09, 2017, 01:50:03 PM »
Could be a flaky sensor or wiring.  Do you have the GMPP tune and/or TMAP sensors?  If so, are they crimped or soldered?

Online Sol Asylum

  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8918
  • Karma: +35/-64
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Re: Thinking I have a leak somewhere.
« Reply #2 on: October 09, 2017, 01:56:03 PM »
When was the last time you checked your spark plugs?
2007 Aggressive GXP

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #3 on: October 09, 2017, 06:17:58 PM »
Never had the plugs out but only 38,000 miles. Tune is a Westers tune so no crimped wires or modified connectors.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Gentleman Jack

  • I haven't been relevant for a while
  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8477
  • Karma: +21/-80
  • Location: Unknown
  • When I'm walkin' I strut my stuff
Re: Thinking I have a leak somewhere.
« Reply #4 on: October 09, 2017, 06:18:44 PM »
Shitty gas?
May the Schwartz be wit you

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #5 on: October 09, 2017, 06:56:58 PM »
Shitty gas?
The fact that the boost goes to 24 and while still in boost drops on the DIC to zero really has me scratching my head and I don't know that gas would cause that. Had bad gas before once and threw misfire codes.
The gas was top tier.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline elff

  • The Devil made me do it
  • Lifetime Supporting
  • General Manager
  • *
  • Posts: 10393
  • Karma: +24/-56
  • Location: Dante's Inferno
    • Ryuk
Re: Thinking I have a leak somewhere.
« Reply #6 on: October 09, 2017, 08:34:54 PM »
Anyone local to you have a copy of HP tuners?  You can scan for codes and log it while driving.
If it's dropping to zero boost, I think you have an air leak or your HPFP is failing and the car is being put into a temp limp mode.

Offline Gentleman Jack

  • I haven't been relevant for a while
  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8477
  • Karma: +21/-80
  • Location: Unknown
  • When I'm walkin' I strut my stuff
Re: Thinking I have a leak somewhere.
« Reply #7 on: October 09, 2017, 10:56:47 PM »
SlyBob-
Do you need HPT back?
May the Schwartz be wit you

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #8 on: October 09, 2017, 11:12:43 PM »
SlyBob-
Do you need HPT back?

Thankyou GJ. Lets see what happens when I check for leaks and see where that gets me. I DO appreciate the offer though.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #9 on: October 10, 2017, 01:18:31 PM »
It appears as though I may in fact have a leak. I have in my possession, a test fitting that Kenny made a number of years ago. Picked it up at one of the glorious mod meets at DeepBlueGXPs place. Oh how I miss those days...

http://www.kappaperformance.com/forum/index.php/topic,5000.msg67971.html#msg67971

ANYWAY, after checking for codes and finding none, I thought I'd go looking for the fitting that Kenny made up. It didn't work as well as I had hoped. The tire valve didn't allow me to hook my compressor to it without holding it there while I looked for the leak. I heard a leak while I held the air chuck on the air valve but couldn't figure out where it was coming from. Went to the hardware store and bought a few pieces from the plumbing section, glued them together, drilled a hole and looked for my 1/4" NPT tap.

Can't find the tap but will pick one up later today.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Online Sol Asylum

  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8918
  • Karma: +35/-64
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Re: Thinking I have a leak somewhere.
« Reply #10 on: October 10, 2017, 03:36:53 PM »
...drilled a hole and looked for my 1/4" NPT tap.

Can't find the tap but will pick one up later today.

I looked in GJ tool box and couldn't find one, what a shitty tool box he doesn't even have a set of taps.
http://www.kappaperformance.com/forum/index.php/topic,11573.msg191768/topicseen.html#new

You can use mine Bob, it's in the bottom drawn on the left there's a metric set and a standard set just under the metric they both have the tap you need.

Now about those mod meets, do you have the room to host one?
2007 Aggressive GXP

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #11 on: October 10, 2017, 06:42:10 PM »
I looked in GJ tool box and couldn't find one, what a shitty tool box he doesn't even have a set of taps.
http://www.kappaperformance.com/forum/index.php/topic,11573.msg191768/topicseen.html#new

You can use mine Bob, it's in the bottom drawn on the left there's a metric set and a standard set just under the metric they both have the tap you need.

Now about those mod meets, do you have the room to host one?

Yeah, any self respecting guy should have taps and I'm just as guilty. I have a standard and a metric set of Snapon taps and dies but mostly straight thread taps. I can find my 1/8" and my 3/8" NPT taps but the 1/4" went missing somehow but having said that, I'll probably come across it next week. Have one now anyway and will continue tomorrow.

Space for a mod meet? Oh I wish... Can't even park on the road around here and only room for two cars in the driveway.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Wartie

  • Lifetime Supporting
  • Master Tech
  • *
  • Posts: 489
  • Karma: +6/-7
  • Location: Stow Ohio
Re: Thinking I have a leak somewhere.
« Reply #12 on: October 10, 2017, 08:54:26 PM »
I looked in GJ tool box and couldn't find one, what a shitty tool box he doesn't even have a set of taps.
http://www.kappaperformance.com/forum/index.php/topic,11573.msg191768/topicseen.html#new

You can use mine Bob, it's in the bottom drawn on the left there's a metric set and a standard set just under the metric they both have the tap you need.

Now about those mod meets, do you have the room to host one?

I have space, we may have to talk next year. I just can't house anybody but tenting would be possible.

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #13 on: October 10, 2017, 11:33:26 PM »
I have space, we may have to talk next year. I just can't house anybody but tenting would be possible.

Hmm, how big of a tent can you get in a Solstice. If it does happen, I for one will be there Bob. That is as long as I have the car fixed by then.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #14 on: October 10, 2017, 11:39:20 PM »
Okay, got home tonight and finished putting the test rig together. 1/4" foster plug in with a ball valve to isolate it, pressure gauge to see what she's holding. Will fire up the compressor tomorrow and see where I am. Don't think it'll be long before the bumper comes off.
Wondering if I need to start looking for an intercooler...

Oh and don't pay any attention to the "Made in USA" sticker. This rig was made in Canada baby!   :tool:
« Last Edit: October 10, 2017, 11:42:43 PM by Sly Bob »
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Gentleman Jack

  • I haven't been relevant for a while
  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8477
  • Karma: +21/-80
  • Location: Unknown
  • When I'm walkin' I strut my stuff
Re: Thinking I have a leak somewhere.
« Reply #15 on: October 11, 2017, 01:19:20 AM »
Tap sets are in the other box.
May the Schwartz be wit you

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #16 on: October 11, 2017, 09:23:27 AM »
Tap sets are in the other box.
So there's another box? What else ya' got you aren't telling us about.   :D
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #17 on: October 11, 2017, 10:56:42 AM »
Okay, hooked everything up this morning, started the compressor, set the regulator to 20 PSI and listened...

Yeah it's leaking, I hope it's not the intercooler I thought. Looking for one last night at work and didn't like what I saw. DDM out of stock, Werks shows it on their site but was going to call this morning if I needed one. Right after asking here if any one had one to sell. I'm getting ahead of myself.   :roll:

Felt around at the connections and found a small leak at a T-bolt clamp downstream of the intercooler where it joins to the pipe that has the Tmap sensor.

[ Guests cannot view attachments ]

Tightened it and thought I was good but wait, I hear more leaks! Feeling around and the clamp below it was leaking. If you put sideways pressure on the connection it leaked worse. Are we done yet? Nope, hear more leaks.

Cranked the pressure to 25 PSI and went to the other side of the intercooler and there was a small leak on the top clamp that when pushed to the side became a bigger leak, tightened that. Of course the bottom clamp was leaking too just for good measure so FINALLY I had all the leaks fixed.

Looked at the gauge I had installed on the piping and it was at 26 PSI.

[ Guests cannot view attachments ]

No more leaks.

Now I haven't road tested yet, I will tomorrow (hopefully) as long as the monsoons let up but I'm pretty confident that was it. I put these charge tubes on the car maybe 6 years ago and haven't touched them since. All T-bolt clamps so what could go wrong? The leaks caused by all the loose clamps combined would be the same as a pretty substantial tear in the intercooler.

I encourage everyone to take an hour of your day and test your system for leaks, you never know what you might find.

Hoping I've put this to bed, will know more when the rain lets up. Can't tell you how relieved I am that I don't need an intercooler.   :yay:
« Last Edit: October 11, 2017, 03:46:56 PM by Sly Bob »
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline elff

  • The Devil made me do it
  • Lifetime Supporting
  • General Manager
  • *
  • Posts: 10393
  • Karma: +24/-56
  • Location: Dante's Inferno
    • Ryuk
Re: Thinking I have a leak somewhere.
« Reply #18 on: October 11, 2017, 06:54:46 PM »
Bob

What you ran into convinced me to ditch T-Bolt Clamps and go back to worm clamps.
I had a leak in the exact same spot, top and bottom.   
all T-Bolt clamps have a flat spot in the circumference where as worm clamps provide 100% 360 degree pressure.  If you aren't careful, it's very easy to over tighten a T-Bolt clamp, cause a flat spot on the aluminum pipe which in turn becomes an air leak.

The problem with most worm clamps is that they are poor quality.  Good ones hold up and actually have an overlap of almost 50% of the circle

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #19 on: October 11, 2017, 07:22:41 PM »
That could well be the problem but where to find good quality worm clamps? That and if I have a flat spot it's not going away. The DDM couplings are fairly rigid. Might go back to the OEM couplers or maybe to a good silicone coupler.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Gentleman Jack

  • I haven't been relevant for a while
  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 8477
  • Karma: +21/-80
  • Location: Unknown
  • When I'm walkin' I strut my stuff
Re: Thinking I have a leak somewhere.
« Reply #20 on: October 11, 2017, 09:14:07 PM »
It's also possible after six years the rubber it's self has started to degrade. Causing some small leaks as the rubber dries out would not be unusual.
May the Schwartz be wit you

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #21 on: October 11, 2017, 10:01:42 PM »
The rubber connectors there were the (silicone?) connectors that DDM supplied with the charge tubes. I still have the stock ones and if I have further issues I'll look at it again. It's so easy to check for leaks I'm going to make it a yearly thing.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline Kelu

  • Lifetime Supporting
  • Shop Foreman
  • *
  • Posts: 5970
  • Karma: +8/-28
  • Location: Romania, Europe
Re: Thinking I have a leak somewhere.
« Reply #22 on: October 11, 2017, 10:56:20 PM »
Also don't forget about vibration, weather and heat/cool cycles. All of these can cause fatigue in tbolts metals over 6 years.
Dragula  ;) Opel GT  from Romania
Arabas: take fotos, videos and keep all girls locked inside the house. Kelu's charm is irresistible !!!!

Online TomatoSoup

  • Lifetime Supporting
  • Gearhead
  • *
  • Posts: 3080
  • Karma: +17/-13
  • Location: Gaithersburg, MD
Re: Thinking I have a leak somewhere.
« Reply #23 on: October 12, 2017, 12:51:15 PM »
I've never understood why GM put T-clamps on the passenger side, and worm clamps everywhere else.  I do know that it's always the factory worm clamps that fail though.
"That is my theory, it is mine, and belongs to me and I own it, and what it is too." (Monty Python)

Offline Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7518
  • Karma: +12/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
Re: Thinking I have a leak somewhere.
« Reply #24 on: October 12, 2017, 04:52:40 PM »
I'm going to look for new couplings for the intercooler, something with a little flex. The straight ones that DDM supplied with the charge tubes are pretty stiff and from my experience don't seem to handle the movement or vibration from the engine very well. As I see it, the engine moves, the intercooler doesn't. Something has to give as Kelu said.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

 

Powered by EzPortal