Welcome Guest!!!

Thank you for visiting the GM Kappa Performance Forum. This forum is the only performance oriented forum for all GM Kappa Platform Enthusiasts.  We hope you will join and share your experiences.  Becoming a member is FREE! If you want to advertise on this forum, email KappaPerformance at yahoo.com.


Registration required to view the forum attachments. Below is a sample of the current top 25 topics.
Supporting Membership has many advantages.


More information on becoming a supporting member or vendor can be found on the sub forum; Site Help and Suggestions; thread - Supporting Members and Vendors.

Author Topic: Have Solo DP and Needed an O2 Extender Now Getting Code P2271 Please Help!  (Read 1875 times)

0 Members and 1 Guest are viewing this topic.

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
So I got the Solo hiflow cat and even after using the O2 extender that came with their kit I got the dreaded P0240. So I went on amazon and got a 90 degree O2 extender.  This eliminated the P0240, but now have a P2271, and am really wondering how I'm going to fix this!

I mean...If I use a straight extender I'm going to still wind up with the P0240, but I get this P2271 with the 90 degree.  Has anyone else had this problem and come up with a fix for it? 

PLEASE I NEED YOUR HELP!!!

Offline Sol Asylum

  • Premium Member
  • Shop Foreman
  • *
  • Posts: 9982
  • Karma: +38/-66
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
First thing to do would be call Solo and ask them, they have been down this road and know what to do to fix the issues, and if I am remembering correctly will supply the parts needed to correct usually at no charge.  They are an outstanding vendor, give them a chance to prove it to you.
2007 Aggressive GXP

Offline LatinVenom

  • Premium Member
  • Gearhead
  • *
  • Posts: 3001
  • Karma: +7/-5
  • Location: South Florida
I mentioned the above information Sol Asylum is posting on the other forum and you mentioned it did not help.
It all has to do with the extender and the signal, and Solo should have a fix for you, this is not new. Weks had the same issues.
Solstice GXP 2007.
Aggressive and fully loaded.
Mods: Magnaflow 2.5" exhaust, DDM Backbone & ProBeam,ZOK suspension,LV Kappa Front Chassis Brace, BTF Turbo Upgraded Wheel, Windristrictor, JPM Center console,arms,tulip,side doors,DDM Upgraded wheel tune.

Online Sly Bob

  • Administrators
  • Shop Foreman
  • *
  • Posts: 7920
  • Karma: +17/-10
  • Location: Welland, Ontario, Canada
  • My new grandson
    • Kappa Performance Forum
I agree with the others that say to call Solo. Their support is outstanding and if you need anything it is typically supplied at no charge.
Just trying to do my part...

Mods: Lose the chicklets, VentureShield, Dual horns, AfterShock spoiler, Weathershield cover, Lil Chromies, Red calipers with black Solstice stickers, Opel GT antenna and Solo GXP-RCD exhaust with a Solo hi-flow cat!

Offline DeepBlueGXP

  • KappaPerformance Site Owner
  • Administrator
  • Shop Foreman
  • *
  • Posts: 9154
  • Karma: +12/-6
  • Location: Southern Maryland
  • Displaced Buffalo Bills Fan
    • Kappa Performance Forum
Did you move the bung back on the exhaust and install the extender?

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
So I did call Solo and they said that they have never had a P2271 with an angled extender, so they recommended that I clear the code (which I did initially) then wait to get it again....They said sometimes the computer just senses something wrong and after clearing it a couple times it will go away.  That's not to say I believe this will happen, but I guess Ill just clear the code a couple of times to see. 

Then I'll have to go back to their extender and use the smaller opening on their extender. 

Offline spicy3480

  • Solo Performance Sales
  • Vendor
  • Gearhead
  • *
  • Posts: 2556
  • Karma: +1/-4
  • Location: New York
Matt,

Keep us posted and we will work with you to solve any issues.  Try what Jeff discussed with you.  Thanks so much and have a great day.

Steve
Steve Mariano
Solo Performance
516-655-9002 (7 days a week, until midnight EST)
goingsolo2@hotmail.com


2007 Mysterious Solstice GXP
INTRUDER

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
Matt,

Keep us posted and we will work with you to solve any issues.  Try what Jeff discussed with you.  Thanks so much and have a great day.

Steve

Thanks!  Basically, my first option will be to wait for the code to throw twice more then clear them.  If the code is thrown four times total I'll have to work on a solution.  I did read about someone with a PAW high flow DP and using a 90degree extender getting the p2271 when they had the extender to the 3 o'clock setting.  The problem was that moving the extender added another code. 

My only other solution will be to go back to the SOLO extender and get the extender with the smaller opening.  It seems like on our cars the straight up and down extenders tend to work better (or at least not throw codes other than the p0420). 

The thing that sucks is that this code takes so long to be thrown!  I'm seriously going to have to wait until around the 200mile mark again for it!

Offline DeepBlueGXP

  • KappaPerformance Site Owner
  • Administrator
  • Shop Foreman
  • *
  • Posts: 9154
  • Karma: +12/-6
  • Location: Southern Maryland
  • Displaced Buffalo Bills Fan
    • Kappa Performance Forum
Thanks!  Basically, my first option will be to wait for the code to throw twice more then clear them.  If the code is thrown four times total I'll have to work on a solution.  I did read about someone with a PAW high flow DP and using a 90degree extender getting the p2271 when they had the extender to the 3 o'clock setting.  The problem was that moving the extender added another code. 

My only other solution will be to go back to the SOLO extender and get the extender with the smaller opening.  It seems like on our cars the straight up and down extenders tend to work better (or at least not throw codes other than the p0420). 

The thing that sucks is that this code takes so long to be thrown!  I'm seriously going to have to wait until around the 200mile mark again for it!
I have the solo high flow cat and exhaust. 

Did you relocate the bung back and to the right and then use the extender they provided?  If not you'll throw codes

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
No...in fact, Solo doesn't have that AT ALL in their directions.  If I have to modify my stock exhaust to put another bung in just to not get a code I'll sell this and go back to stock.

Offline DeepBlueGXP

  • KappaPerformance Site Owner
  • Administrator
  • Shop Foreman
  • *
  • Posts: 9154
  • Karma: +12/-6
  • Location: Southern Maryland
  • Displaced Buffalo Bills Fan
    • Kappa Performance Forum
No...in fact, Solo doesn't have that AT ALL in their directions.  If I have to modify my stock exhaust to put another bung in just to not get a code I'll sell this and go back to stock.
perhaps their design was changed but originally if you placed the extender on the original location, there was interference with the O2 sensor and the bottom of the car

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
So I had the code again.  I cleared it and will wait one last time for it to throw the same code....then I'll be contacting SOLO performance again for a fix.

Offline elff

  • Premium Member
  • General Manager
  • *
  • Posts: 11144
  • Karma: +26/-58
  • Location: Keebler Tree House
    • Ryuk
Is this code anything beyond an annoyance?
The only reason I ask that is, you should be able to disable it in HP Tuners.

I had the SoloHF Cat on my Sky and once I added the straight extender, had zero issues.  Without the extender, I only blew the P0420

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
Well the one I'm getting now is making me run rich in non wot mode.

Offline TomatoSoup

  • Premium Member
  • Gearhead
  • *
  • Posts: 3293
  • Karma: +18/-13
  • Location: Gaithersburg, MD
Well the one I'm getting now is making me run rich in non wot mode.

Well *I* don't know.  Wot mode is it making you run rich in?


(sorry) :devil:
"That is my theory, it is mine, and belongs to me and I own it, and what it is too." (Monty Python)

Offline Sol Asylum

  • Premium Member
  • Shop Foreman
  • *
  • Posts: 9982
  • Karma: +38/-66
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Well *I* don't know.  Wot mode is it making you run rich in?


(sorry) :devil:

Wot the hell are you talking about?  Clearly he wants to be running in the mode that makes him rich not poor.
2007 Aggressive GXP

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
Wow guys!  Ok....I get closed and open loop mode confused.  I suppose the code makes your car run a rich afr in open loop mode versus WOT when you are in closed loop mode. 

Those posts were very helpful with regard to the problem I posted the thread about.  Thanks! 

Offline Steelmesh

  • Premium Member
  • Master Tech
  • *
  • Posts: 670
  • Karma: +5/-2
  • Location: Detroit Metro
    • Kappadapt
So I got the Solo hiflow cat and even after using the O2 extender that came with their kit I got the dreaded P0240. So I went on amazon and got a 90 degree O2 extender.  This eliminated the P0240, but now have a P2271, and am really wondering how I'm going to fix this!

I mean...If I use a straight extender I'm going to still wind up with the P0240, but I get this P2271 with the 90 degree.  Has anyone else had this problem and come up with a fix for it? 

PLEASE I NEED YOUR HELP!!!

I am making question in a jokingly way because this is my experience: Do the post-cat O2 trick extender thingies ever work? And then reliably? I'm curious if you have had success and what powertrain.

Google says P0240 is a Turbocharger boost sensor code.  How is that conflated with an oxygen sensor? In other question words, how can a post-cat O2 sensor impact the Boost sensor? Could this be another problem? 

If you have an off-road vehicle, then you can build or buy an O2 emulator, well actually are those still a thing these days? The bandaid I employed on my off-road racecar is: disable the MIL using HPT.

Well the one I'm getting now is making me run rich in non wot mode.

If you change the dynamics of air flow at the MAF or I think the O2 Sensor 1 (different pipe), the closed loop (computer targeting stoich for us) fueling will change but more pronouced with MAF tube changes really.
2006 Solstice #1458, Twincharged LE5/LEA, 5757+M62, Werks exh manifold, Tial bpv/wg, Cams, dual meth, 40 PSI, Kappadapt clutch hose/flywheel bolts/trans mount, Aisin AR5, Stage 5 clutch
Turbo-only power 444whp/422wtrq

2013 Cruze Missile, tuned, 42 lb, ZZP SRI/FMIC/DP/MP/CB, Kappadapt trans mount

Support Kappaperformance.com!!  Note: a couple huge corporations own and control several hundred of the top automotive enthusiast forums subsequently profiteering from these communities on the backs of volunteer moderators.

Offline elff

  • Premium Member
  • General Manager
  • *
  • Posts: 11144
  • Karma: +26/-58
  • Location: Keebler Tree House
    • Ryuk
I am making question in a jokingly way because this is my experience: Do the post-cat O2 trick extender thingies ever work? And then reliably? I'm curious if you have had success and what powertrain.


Yes
2008 Saturn Sky
2.0L Ecotec
2871 Garrett Turbo Hybrid
E47 Tune

Zero issues, and no P0420 code when running the extender.

That brings up another point, was the car retuned after this was added?
The additional air flow is not something the computer will learn into.  The commanded AFR will need to be adjusted, logged for actual AFR, then rinse and repeat as needed. 


Offline wspohn

  • Master Tech
  • ***
  • Posts: 874
  • Karma: +1/-4
I have the Solo extender on my car with the big wheel turbo and custom Trifecta tune.  Never a code. Wonder what is going on with your car...?
2009 Pontiac Solstice GXP Coupe
1958 MGA Twincam (race car)
1962 MGA Deluxe Coupe
1957 Jamaican bodied MGA
1971 Jensen Interceptor
2007 BMW Z4M coupe
Recently sold:
1969 MGC roadster,
1965 Jensen CV8,
1969 Lamborghini Islero S
1988 Pontiac Fiero GT
Bill in BC

Offline Sol Asylum

  • Premium Member
  • Shop Foreman
  • *
  • Posts: 9982
  • Karma: +38/-66
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Damage something else during the removal of the old exhaust/install of the Solo exhaust?
2007 Aggressive GXP

Offline DeepBlueGXP

  • KappaPerformance Site Owner
  • Administrator
  • Shop Foreman
  • *
  • Posts: 9154
  • Karma: +12/-6
  • Location: Southern Maryland
  • Displaced Buffalo Bills Fan
    • Kappa Performance Forum
I have an 07, 08 and 09 Solstice with the high flow cat and extender with no issues.  The 08 was DarkTech GXP, it's now sold....

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
This isn't really about damaging anything, it's about what I needed to do to stop throwing codes.  When I put the original Solo extender in I still got the P0420 code.  I had that 90 degree extender (different type of extender) and tried that.  Now, I'm not getting the p0420 code (which is good), but i'm now getting the other code (which is bad).  That code is likely as a result of the amount of space from the exhaust to the sensor as well as the 90 degree angle. 

Once I contact SOLO, I'll probably just get their straight extender, but with the smaller opening (should fix it). 

Offline MattM

  • Master Tech
  • ***
  • Posts: 380
  • Karma: +0/-0
  • Location: Mechanicsburg PA
One thing I have been wondering with the P2271 code has to do with the fact that a "Clogged Air Filter" can cause that to be through.  I checked the air filter and it looked ok to me, but I did notice that my IAT2s were pretty high when I would go WOT.  I would think that could also be caused by a clogged air fillter.

Anyway, from what I'm reading on this code the first thing they usually do is make sure the air intake isn't clogged.....I'm thinking/hoping this might kill two birds with one stone in changing this....

Offline Steelmesh

  • Premium Member
  • Master Tech
  • *
  • Posts: 670
  • Karma: +5/-2
  • Location: Detroit Metro
    • Kappadapt
I couldn't find this code in the 2006 Solstice alldatadiy information, but found it under my Cruze 1.4T haha. Just putting this here you probably already looked at it:

P2271
The ECM detects that the heated oxygen sensor (HO2S) 2 sensor cannot achieve voltage equal to or less than 100 mV. and
The ECM detects that the accumulated mass air flow monitored during the stuck rich voltage test is more than 25 g.

Have you already or do you have the ability to monitor both of HO2S voltage and MAF or cylinder/g?  This could be a good excuse to get HPT  :D  edit: I just looked up in my E67 LE5 ECU for "accumulated" mass air flow and can't find this PID to monitor, so not sure what 25 g means, looking furthur I see around idle the cylinder airmass is 0.08 g/sec, * 4 cylinders = 0.32 g/sec, then 25 g divided by 0.32 g/sec = 78 seconds, so looks like its just integrating the mass like I just calculated, 78 seconds seems reasonable from my understanding.

Conditions for Running the DTC:
DTCs P0068, P0096, P0097, P0098, P00B6, P0101, P0102, P0103, P0106, P0107, P0108, P0111, P0112, P0113, P0114, P0116, P0117, P0118, P0119, P0121, P0122, P0123, P0171, P0172, P0201, P0202, P0203, P0204, P0222, P0223, P0300, P1101, P1516, P2096, P2097, P2101, P2119, P2135, P2176 are not set.
The ignition signal parameter is between 10-32 V.
The fuel level is greater than 10%.
The engine speed parameter is between 1 100-3 500 RPM.
The mass air flow (MAF) sensor parameter is between 1-30 g/s.
The fuel composition is less than 87% ethanol.
The fuel system is in Closed Loop.
DTC P013A, P013B, P013E, P013F and P2270 have run.
DTC P013A, P013E and P2270 have passed.
DTC P2270 runs once per drive cycle when the above conditions are met for 5 s.

Not sure why it is mentioning P2270 in the above, this is conditions for setting P2271 so idk
« Last Edit: June 12, 2019, 08:03:48 AM by Steelmesh »
2006 Solstice #1458, Twincharged LE5/LEA, 5757+M62, Werks exh manifold, Tial bpv/wg, Cams, dual meth, 40 PSI, Kappadapt clutch hose/flywheel bolts/trans mount, Aisin AR5, Stage 5 clutch
Turbo-only power 444whp/422wtrq

2013 Cruze Missile, tuned, 42 lb, ZZP SRI/FMIC/DP/MP/CB, Kappadapt trans mount

Support Kappaperformance.com!!  Note: a couple huge corporations own and control several hundred of the top automotive enthusiast forums subsequently profiteering from these communities on the backs of volunteer moderators.

 

Powered by EzPortal