Welcome Guest!!!

Thank you for visiting the GM Kappa Performance Forum. This forum is the only performance oriented forum for all GM Kappa Platform Enthusiasts.  We hope you will join and share your experiences.  Becoming a member is FREE! If you want to advertise on this forum, email KappaPerformance at yahoo.com.


Registration required to view the forum attachments. Below is a sample of the current top 25 topics.
Supporting Membership has many advantages.


More information on becoming a supporting member or vendor can be found on the sub forum; Site Help and Suggestions; thread - Supporting Members and Vendors.

Author Topic: PLX guage problems  (Read 1633 times)

0 Members and 1 Guest are viewing this topic.

Offline Richfly

  • Founding Member
  • Apprentice/Gofer
  • *
  • Posts: 8
  • Karma: +0/-0
PLX guage problems
« on: February 01, 2009, 04:50:47 PM »
Hey guys just installed the DM5 PLX boost guage. It`s all powered up but for some reason I`m not getting any Boost reading on the guage, it stays at O.O,  the attached picture is where I spliced in for boost. Any suggestion?


Offline Sol Asylum

  • Premium Member
  • General Manager
  • *
  • Posts: 10013
  • Karma: +39/-66
  • Location: Tolono Illinois
  • THAT'S MISTER KAPPA ASSYLUM TO YOU!
Re: PLX gauge problems
« Reply #1 on: February 01, 2009, 04:58:58 PM »
I am not sure about this and someone else will surely correct me if I am wrong but, its possible that you tapped into the wrong side and the line you are pulling from is actually a reference line which will show ambient pressure and not boost pressure.  You could try to simply move your "T" to the other side of the factory sensor.

Have you tested out the gauge to make sure it was working to begin with?  Does it measure vacuum as well as boost?
2007 Aggressive GXP

Offline Critterman

  • Retired, thank you very much
  • Premium Member
  • General Manager
  • *
  • Posts: 13274
  • Karma: +17/-58
  • Baltimore/Washington Corridor
Re: PLX guage problems
« Reply #2 on: February 01, 2009, 05:35:47 PM »
I have the PLX-5 as well and it measures boost and vacum.  You might check with the guys at DDMWorks.
2006 Cool named BIXABEL (BISH-AH-BEL) Mayan for "Good Roads"

DDM
StageIII intercooled Supercharger, Wisco ceramic coated pistons, Carrillo rods, superTech valves and Springs
Ported and polished head
Exedy Stage II Clutch
big brake kit, slotted/drilled Rotors w/Porterfield pads & blue juice
Backbone, Probeam, Cross Strut Brace
Underhood, trunk, & door Lights
ZOK suspension

JPM
Center console, door inserts, & dash
Seat bolster & lumbar support

Focuztech Tri-Y Header & hi-flow cat
Solo Performance SQR-2
Norm's Rear facia
Heated Seats
Black Cat inserts

Offline Richfly

  • Founding Member
  • Apprentice/Gofer
  • *
  • Posts: 8
  • Karma: +0/-0
Re: PLX guage problems
« Reply #3 on: February 01, 2009, 09:23:20 PM »
I checked with DDM works and Dave said it`s all hooked up right. I tryed a few things, pluging and unpluging connections and all of a sudden the guage started to work, go figure!

Offline Critterman

  • Retired, thank you very much
  • Premium Member
  • General Manager
  • *
  • Posts: 13274
  • Karma: +17/-58
  • Baltimore/Washington Corridor
Re: PLX guage problems
« Reply #4 on: February 01, 2009, 09:58:02 PM »
You had to have a loose connection somewhere, glad it is working for you.
2006 Cool named BIXABEL (BISH-AH-BEL) Mayan for "Good Roads"

DDM
StageIII intercooled Supercharger, Wisco ceramic coated pistons, Carrillo rods, superTech valves and Springs
Ported and polished head
Exedy Stage II Clutch
big brake kit, slotted/drilled Rotors w/Porterfield pads & blue juice
Backbone, Probeam, Cross Strut Brace
Underhood, trunk, & door Lights
ZOK suspension

JPM
Center console, door inserts, & dash
Seat bolster & lumbar support

Focuztech Tri-Y Header & hi-flow cat
Solo Performance SQR-2
Norm's Rear facia
Heated Seats
Black Cat inserts

 

Powered by EzPortal